You need at least Adobe Flash Player version 10.1!

Get Adobe Flash player